04 Ağustos 2009

WordPress 2.8.3 Güvenlik Yaması

WordPress Yorum Ekle

WordPress 2.8.2 sürümünün üzerinden henüz kısa bir süre geçmiş olmasına rağmen, 2.8.3 sürümü yeni bir güvenlik yaması daha yayımlandı. Geliştiriciler, güncellemenin yapılmasını şiddetle tavsiye ediyorlar. Güncelleme yaparken otomatik güncelleştirme yerine elle, dosyaları ftp kullanarak göndermenizi tavsiye ederim. Güncelleme sadece dosyalar üzerinde yapıldığından veritabanı ile ilgili bir güncelleme yapılmayacak. Her zaman olduğu gibi güncelleme yapmadan önce sitenizin tam bir yedeğini almanızı şiddetle tavsiye ediyorum.
Güncelleme ile ilgili WordPress tarafından yapılan habere ulaşmak için buraya, WordPress 2.8.3 sürümünü indirmek için ise buraya zıplayın.
Türkçe sürümü indirmek için ise tıklayın.


Bu yazının kısa bağlantısı http://www.yakupgovler.com/?p=951.

Yazılarımı RSS aboneliği ile takip edebilir, yeni yazılarıma kolaylıkla ulaşabilirsiniz. Bunun için ise RSS adresimi kullanabilirsiniz.


“WordPress 2.8.3 Güvenlik Yaması” yazısı için 3 Yorum

Bu yazıya yapılan yorumları dilerseniz, ( RSS 2.0 ) beslemesini kullanarak takibe alabilirsiniz.

  1. serdar dedi ki:

    hocam aklımın almadığı bir konu var, açıklayabilirseniz veya çözebilirseniz çok sevinirim.

    ben 2.6.5 kullanıyordum ve 2.8 e güncelleme yaptım.(sırayla). fakat güncellemeden sonra google sitemap generator eklentisi şu hatayı vermeye başladı. (diğer sitemap eklentileri de)

    [code]Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 47 bytes) in /home/wp-settings.php on line 288[/code]

    bu soruyu başka kimseye sormadım, çünkü cevap aynı olacak. 'sunucudan kaynaklanıyor, php.ini veya htacces dosyasını ayarlayın ve limit yükseltin'

    birisi bana da sorsa aynı cevabı verirdim. ilk bakışta sunucu hatası gibi görünüyor ama bu hatayı 2.6.5 de vermiyor.şimdi, host aynı, içerik yani db aynı, eklenti aynı ama neden eski sürümde böyle bir hata vermiyor da yeni sürümde böyle bir hata veriyor?

    sitemap benim için önemli olduğundan yedekle geri döndüm ve yine sorunsuz çalışıyor. bir anlam veremedim bunun bir çözümü var mıdır? yeni sürümde bir kod yüzünden mi oluyor acaba? şimdiden teşekkür ederim. kolay gelsin...

  2. gevv dedi ki:

    Teşekkürler hocam. Eskiden güncelleme hakkında bilgi verilirdi şu dosya içeriği değişti diye sadece o dosyayı günceller bir sürü dosya silme yükleme sıkıntısı olmazdı nedense uzun süredir bu bilgilere ulaşılamıyor acaba bu bilgiyide güvenlik içinmi gizli tutuyorlar :)

  3. Yakup Gövler dedi ki:

    WordPress 2.8 sürümü ile birlikte çoğu kimse farketmese de kodlamada farklılıklar geldi. Bu nedenle de hataların olması kaçınılmaz ki kısa sürede bu kadar yamanın çıkması bunun göstergesi. Hangi dosyalarda değişiklik olduğunu açıklamamaları güvenlik öte (çünkü hangi dosyalarda değişiklik yapıldığına http://core.trac.wordpress.org/browser/trunk adresinden bakılabiliyor), birçok dosyada değişiklik yapılmasından veya acemilerin bu işi becerememesinden olabilir. Her ne kadar bütün dosyaları atmak 5-10 dakika alsa da yine de can sıkabiliyor, bu konuda haklısın.